Install Middleman

Prerequisites

libgmp3-dev

If you are getting error messages about having "to install development tools", then install the libgmp3-dev package 2016-08-26 09:51:09 -0400:

sudo apt-get install libgmp3-dev

ruby 2+

If you are not using Ruby 2+, then you must install this to use the latest Middleman (as of 3/21/2016).

rvm install 2.3.0

Javascript runtime gem install therubyracer

Finally…

gem install middleman

Next the blogging extension… gem install middleman-blog middleman init HealthHacker --template=blog

Time for our first article! middleman article Blogging with Middleman